
SRAM Chart: Guide to Troubleshooting Problems with SRAM Cards

What is your PC Operating System?

Windows 98 Windows 2000 Windows NT Windows ME Windows XP

Run Memcard.exe

What product are you using?

PP1

SRAM Card Only

4300 TASK PQLite4300 TASK 808

Upgrade to
Flash RAM

For Adtron Data DriveFor Laptop Internal Drive

Does SRAM have a sticker
that says "Windows 2000 and
Windows XP compatible"?

If Yes: Follow  the SRAM -
PCMCIA Card Installation
Guide

If No: Upgrade SRAM Card

When using Win 98, Win
2000, Win ME or Win NT,
download driver from
www.adtron.com, Tech
Support section

When using Win XP,
Adtron does not have
drivers. Possible work
around is to partition your
hard drive and run Win 98
from the partition.

NOTE: Click on dotted box to open link.

ftp://marketing.dranetz-bmi.com/memcard.exe
http://www.adtron.com/tech.html
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1.  Windows 98 SE Installation

NOTE: The Windows 98 SE Installation CD is required in order to proceed with this
installation. For successful installation, do not insert the SRAM Card until you are told
to do so.

1.1. Turn on your laptop computer and wait until it finishes loading Windows.

1.2. Format the SRAM Card (if you haven't done so) by using either a PP1 or 4300 unit.

1.3. Insert the Windows 98 SE CD into the CD tray. (If the following screen appears close it.)

1.4. Go to Windows Explorer, Click on the “+” next to the CD drive to expand the contents of the
Windows 98 SE CD. Expand Drivers and Storage folders, then click on ftl folder to display its
contents.
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1.5. Right click on trueffs.inf then click Install. (If the extensions are hidden and you don’t know how
to unhide them go to Appendix A on page 26.)

1.6. Restart the system by clicking on Start > Shutdown > Restart, then click on OK.

1.7. Wait until the PC finishes rebooting then insert the AVED SRAM (2MB or 4MB) Card into one of
the laptop PCMCIA slots. Wait a couple of seconds until Windows loads the drivers. An icon
similar to the one below should appear on the lower right side of the task bar.
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1.8. At this point you have completed the installation. Go to Windows Explorer and look for your
new drive which will typically appear as Removable disk (D:) or (E:) or (F:).

To remove the SRAM Card properly you must stop the device first. See Appendix B on
page 27 for more details.

NOTE: When operating on a network environment, you may have to remap your drive
paths if the SRAM Card took the place of a previously mapped network drive. If this
is the case, in Windows Explorer disconnect the affected drive paths and then
remap them as necessary.
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2. Windows ME Installation

NOTE: The Windows ME Installation CD is required in order to proceed with this installation.
    For successful installation, do not insert the SRAM Card until you are told to do so.

2.1. Turn on your laptop computer and wait until it finishes loading Windows.

2.2. Format the SRAM Card (if you haven’t done so) by using either a PP1 or 4300 unit.

2.3. Insert the WinME CD into the CD tray. (If the following screen appears close it.)

2.4. Go to Windows Explorer, Click on the “+” next to the CD drive to expand the contents of the
Windows ME CD. Expand Drivers and Storage folders, then click on flash folder to display its
contents.
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2.5. Right click on trueffs.inf then click Install. (If the extensions are hidden and you don’t know how
to unhide them go to Appendix C on page 28.)

2.6. Restart the system by clicking on Start > Shutdown > Restart, then click on OK.

2.7. Wait until the PC finishes rebooting then insert the AVED SRAM (2MB or 4MB) Card into one of
the laptop PCMCIA slots. Wait a couple of seconds until Windows loads the drivers. An icon
similar to the one below should appear on the lower right side of the task bar.



AVED SRAM-PCMCIA CARD

Installation Guide
FOR LAPTOP COMPUTERS

◄ Return to SRAM Chart

Dranetz-BMI • 1000 New Durham Road • Edison, New Jersey  08818
Telephone 1-800-372-6832 or 732-287-3680
Fax 732-248-1834 • www.dranetz-bmi.com

\899096.doc  1/4/02

8

2.8. At this point you have completed the installation. Go to Windows Explorer and look for your
new drive which will typically appear as Removable disk (D:) or (E:) or (F:).

To remove the SRAM Card properly you must stop the device first. See Appendix D on
page 29 for more details.

NOTE: When operating on a network environment, you may have to remap your drive
paths if the SRAM Card took the place of a previously mapped network drive. If this
is the case, in Windows Explorer disconnect the affected drive paths and then
remap them as necessary.
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3. Windows NT 4.0 Installation

NOTE: The software CardWare 6.0 is required in order to proceed with this installation.

For successful installation, the following are required:
 Do not insert the SRAM Card until you are told to do so
 Your laptop should have Service Pack 6 installed

3.1. Turn on your laptop computer and wait until it finishes loading Windows.

3.2. Format the SRAM Card (if you haven’t done so) by using either a PP1 or 4300 unit.

3.3. Insert the AVED SRAM (2MB or 4MB) Card into one of the laptop PCMCIA slots.

3.4. Insert the CardWare Software Installation Disk #1 into your floppy drive. Click on Start > Run,
and type A:\Setup in the box. Click OK when done.

3.5. The next screen will prompt you to insert Disk #2. Click OK when done.

3.6. The next screen will prompt you to insert Disk #3. Click OK when done.



AVED SRAM-PCMCIA CARD

Installation Guide
FOR LAPTOP COMPUTERS

◄ Return to SRAM Chart

Dranetz-BMI • 1000 New Durham Road • Edison, New Jersey  08818
Telephone 1-800-372-6832 or 732-287-3680
Fax 732-248-1834 • www.dranetz-bmi.com

\899096.doc  1/4/02

10

3.7. The CardWare Setup screen appears. Click on Next to continue.

3.8. Click on Next to install the CardWare in the default directory (Recommended) or click on
Browse to choose a different directory.

3.9. Click the down arrow to display the menu from which to select the type of platform (computer)
that you are using. If the PC is not in the list, select Unlisted Notebook (controller: PCIC
family). Then select 'Express Setup' and click on Next.
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3.10. The next screen will prompt you to insert Disk #4. Click OK when done.

3.11. You will be asked to restart the computer. Remove the disk from the drive and click on Finish.

3.12. The next screen will prompt you to type in the Serial Numer provided by the manufacturer. Click
OK when done.

3.13. Insert the SRAM Card (2MB or 4MB) in one of the PCMCIA slots. A screen similar to the one
below will appear for a couple of seconds along with a series of beeps.
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3.14. At this point you have completed the installation. Go to Windows Explorer and look for your
new drive which will typically appear as Removable disk (D:) or (E:) or (F:).

To remove the SRAM Card properly you must stop the device first. See Appendix E on
page 30 for more details.

NOTE: When operating on a network environment, you may have to remap your drive
paths if the SRAM Card took the place of a previously mapped network drive. If this
is the case, in Windows Explorer disconnect the affected drive paths and then
remap them as necessary.
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4. Windows 2000 Installation

NOTE: For successful installation, the following are required:
 Do not insert the SRAM Card until you are told to do so
 Your laptop must have at least the Service Pack 1 installed
 Apply the procedure individually for each type of SRAM Card (ex. 2MB or 4MB SRAM Card)

4.1. Turn on your laptop computer and wait until it finishes loading Windows.

4.2. Format the SRAM Card (if you haven’t done so) by using either a PP1 or 4300 unit.

4.3. Insert the AVED SRAM (2MB or 4MB) Card into one of the laptop PCMCIA slots. A window
similar to the one below will appear.

4.4. If you hear two consecutive beeps and the Found New Hardware window disappears from the
screen, it means that Windows loaded the drivers automatically. In that case go to step 4.25.
Otherwise, continue with step 4.5.

4.5. At the following screen click on Next.
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4.6. Select Display a list of the Known drivers for ....., then click on Next.

4.7. From the list, select PCMCIA and Flash memory devices.  Click on Next.

4.8. From the Manufacturers window select the M-Systems Flash Disk Pioneers. From the
Models window select M-Systems DiskOnChip 2000. Then Click on Next.
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4.9. The Update Driver Warning screen appears. Click on Yes to continue.

4.10. Click on Next to start the driver installation.

4.11. Click on Finish to continue with the installation.
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4.12. You will be asked to restart the computer. Click on NO to continue with the installation.

4.13. Click on Start > Settings > Control Panel. Locate the System icon then double click.

4.14. Select the Hardware tab, then click on Device Manager.
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4.15. Expand the PCMCIA and Flash memory devices, then right click on M-Systems DiskOnChip
2000. From the drop-down menu click on Properties.

4.16. Select the Driver tab, then click on Update Driver.
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4.17. At the following screen click on Next to upgrade the device driver.

4.18. Select Display a list of the Known drivers for....., then click on Next.
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4.19. From the Manufacturers window select Generic. From the Models window select Generic
PCMCIA Memory Card. Click on Next.

4.20. The Update Driver Warning screen appears. Click on Yes to continue.

4.21. Click on Next to continue with the installation. You are going to hear two consecutive beeps.
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4.22. Click on Finish to end the installation wizard.

4.23. From the Generic PCMCIA Memory Card Properties screen, click on Close.

4.24. You will be asked to restart the system. Click on Yes to restart.
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4.25. At this point you have completed the installation. Now go to Windows Explorer and look for your
new drive which will typically appear as Removable disk (D:) or (E:) or (F:).

To remove the SRAM Card properly you must stop the device first. See Appendix F on page 31
for more details.

NOTE: When operating on a network environment, you may have to remap your drive paths if
the SRAM Card took the place of a previously mapped network drive. If this is the case,
in Windows Explorer disconnect the affected drive paths and then remap them as
necessary.
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5. Windows XP Installation

NOTE: For successful installation, the following are required:
 Do not insert the SRAM Card until you are told to do so
 Apply the procedure individually for each type of SRAM Card (ex. 2MB or 4MB SRAM Card)

5.1. Turn on your laptop computer and wait until it finishes loading Windows.

5.2. Format the SRAM Card (if you haven’t done so) by using either a PP1 or 4300 unit.

5.3. Insert the AVED SRAM (2MB or 4MB) Card into one of the laptop PCMCIA slots. A Found New
Hardware pop up menu similar to the one below will appear.

5.4. If a second Found New Hardware menu similar to the one below appeared specifying that Your
new hardware is installed and ready to use, it means that Windows loaded the drivers
automatically. In that case go to step 5.12. Otherwise, continue with step 5.5.

5.5. From Found New Hardware Wizard screen select Install from a list or specific location.
Then click on Next to continue.
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5.6. From the following screen select Don’t search. I will choose the drivers to install. Then click
on Next.

5.7. From the list, select PCMCIA and Flash memory devices. Click on Next.

5.8. From the Manufacturers window select Generic. From the Models window select Generic
PCMCIA Memory Card. Click on Next.
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5.9. The Update Driver Warning screen appears. Click on Yes to continue.

5.10. Click on Finish to start the driver installation.

5.11. A pop up menu similar to the one below will appear confirming the driver installation.
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5.12. At this point you have completed the installation. Now go to Windows Explorer and look for
your new drive which will appear as PCMCIA Card(X:) or Local Disk(X:). Where X can be any
letter from A to Z.

To remove the SRAM Card properly you must stop the device first. See Appendix G on
page 32 for more details.

NOTE: When operating on a network environment, you may have to remap your drive
paths if the SRAM Card took the place of a previously mapped network drive. If this
is the case, in Windows Explorer disconnect the affected drive paths and then
remap them as necessary.
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Appendix A

Windows 98 SE

How to unhide hidden File Extensions

1. Go to Windows Explorer. Then click on Tools > Folder Options.

2. From the Folder options menu select the View tab, then deselect the check from the box next to Hide
files extensions for known file types. Click on Apply then on OK.

3. Now you should be able to see the file extensions.
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Appendix B

Windows 98 SE

Removing the SRAM Memory Card from the PCMCIA slot

1. Single click on the PC Card icon on the right side of the task bar. Then click on Stop Static RAM
Memory Card.

        click here

2. The following message will appear.

3. Click on OK, then remove the device.

NOTE:  Removing the SRAM Card without first stopping the device is not recommended.
This could cause a malfunction in the device that may lead to data lost and/or lost
of the SRAM format. In case of lost of format, the Card needs to be reformatted by
either the PP1 or 4300 unit.
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Appendix C

Windows ME

How to unhide hidden File Extensions

1. Go to Windows Explorer. Then click on Tools > Folder Options.

2. From the Folder options menu select the View tab, then remove the check from the box next to Hide
files extensions for known file types. Click on Apply then on OK.

3. Now you should be able to see the file extensions.
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Appendix D

Windows ME

Removing the SRAM Memory Card from the PCMCIA slot

1. Single click on the unplug/eject icon on the right side of the task bar. Then click on Stop Static RAM
Memory Card – Drive(X:).

             click here

2. The following message will appear.

3. Click on OK, then remove the device.

NOTE:  Removing the SRAM Card without first stopping the device is not recommended.
This could cause a malfunction in the device that may lead to data lost and/or lost
of the SRAM format. In case of lost of format, the Card needs to be reformatted by
either the PP1 or 4300 unit.
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Appendix E

Windows NT 4.0

Removing the SRAM Memory Card from the PCMCIA slot

1. Single click on the PC Card icon on the right side of the task bar. A menu will appear. Select Slot
Power Off then click on the device name (ex: KINGMAX TECHOLOGY.….).

        click here

2. The following screen will appear for a couple of seconds. Now you can remove the memory card from
the PCMCIA slot.

NOTE:  Removing the SRAM Card without first stopping the device is not recommended.
This could cause malfunction in the device that may lead to data lost and/or lost of
the SRAM format. In case of lost of format, the Card needs to be reformatted by
either the PP1 or 4300 unit.



AVED SRAM-PCMCIA CARD

Installation Guide
FOR LAPTOP COMPUTERS

◄ Return to SRAM Chart

Dranetz-BMI • 1000 New Durham Road • Edison, New Jersey  08818
Telephone 1-800-372-6832 or 732-287-3680
Fax 732-248-1834 • www.dranetz-bmi.com

\899096.doc  1/4/02

31

Appendix F

Windows 2000

Removing the SRAM Memory Card from the PCMCIA slot

1. Single click on the unplug/eject icon on the right side of the task bar. Then click on Stop Generic
PCMCIA Memory Card – Drive(X:).

             click here

2. The following message will appear.

3. Click on OK, then remove the device.

NOTE:  Removing the SRAM Card without first stopping the device is not recommended.
This could cause malfunction in the device that may lead to data lost and/or lost of
the SRAM format. In case of lost of format, the Card needs to be reformatted by
either the PP1 or 4300 unit.
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Appendix G

Windows XP

Removing the SRAM Memory Card from the PCMCIA slot

1. Single click on the unplug/eject icon on the right side of the task bar. Then click on Stop Generic
PCMCIA Memory Card – Drive(X:).

           click here

2. The following message will appear on the lower right side of the screen. Now it is safe to remove the
SRAM Card from the PCMCIA slot.

NOTE:  Removing the SRAM Card without first stopping the device is not recommended.
This could cause a malfunction in the device that may lead to data lost and/or lost
of the SRAM format. In case of lost of format, the Card needs to be reformatted by
either the PP1 or 4300 unit.
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New Memory Card for PP4300 PQLite with CompactFlash card support

The previous PQLite TASKCards supported SRAM memory (data) cards (CARD-2M and
CARD-4M) available for use with the PP4300 have been supplemented with a CompactFlash
type card (FLASH-32M).  This new enhancement supports the use of CompactFlash cards and
can only be used with TASKCard®  PQLite V4.2 (or later) which supports the use of
CompactFlash or SRAM cards. These cards serve as a removable, rugged, compact, solid-
state mass storage device for data that can be viewed or analyzed at a later date.

Note: Previously purchased Dranetz-BMI 2 Mbyte (CARD-2M) and 4 Mbyte (CARD-4M) SRAM
cards are supported by TASKCard PQLite V4.2 (or later) and can be used for data storage if
desired as well as other optional TASKCards used with the PP4300.

This TASKCard and CompactFlash card upgrade feature include the following:

 Increased data storage size.
 Auto-transfer files up to 8Mb.
 Storage of multiple data files.
 Improved speed performance during formatting and file creation.

Available Optional CompactFlash Card Readers

Two types of card readers are available for easy data manipulation and transferring data from
the CompactFlash card to a computer for further analysis. Either a USB port FLASHREADER-
USB) or a parallel port (FLASHREADER-P) type card reader are available contact our
Customer Service department for pricing and availability.
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Using the CompactFlash Card with the PP4300

  Insert the CompactFlash Card into the PCMCIA adapter.

  Insert the PCMCIA (with the CompactFlash) fully into the data card slot on the Power
Platform 4300 until resistance is felt, then press firmly until the card engagement is felt.

NOTE: Do not force the card further into the slot if no card engagement is felt. Remove card
and check that there is no foreign object on or in the plug end of the card. Remove any
obstruction. Reinsert card and repeat card engagement. If card cannot be engaged, stop all
further action and call Dranetz Service for further instructions.

ComapctFlash Card
PCMCIA Adapter
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Using the CompactFlash Card with TASKCard®  PQLite V4.2 (or later)

The TASKCard PQLite V4.2 (or later) utilizes the CompactFlash Card like a floppy disk storing
files in DOS format. For successful file transfers, observe the following guidelines.

Auto-transfer functions:
• PQLite V4.2 only supports a maximum data size of 32MB. If you use CompactFlash cards

that are larger than 32MB, the data file on the 4300 will only be formatted to use up 32MB
space and will render the remaining space unusable.

• The maximum size for auto-transfer file has increased from 4MB to 8MB and you can now
store multiple auto-transfer files on one card. The Site ID will be used as the file name (i.e. if
the site name is SITE_1, the file name will be SITE_1.MDB). To create an auto-transfer file,
refer to the PP4300 TASKCard PQLite User's Guide, Chapter 7 'Saving Data'.

• PQLite V4.2 does not support file fragmentation. When creating an auto-transfer file, it will
look for a contiguous block of 8MB and use that size block for data storage. If the remaining
space is less than 8MB, it will use the largest block it can find that is greater than 1MB. If
you use a block less than 8 MB the card may be fragmented and you may not get optimum
results or lose data. Also, we do not recommend deleting files from the memory card on the
4300. Whenever possible, reformat the card using the Power Platform 4300 when there is
no more space available to begin new data storage.

Manually saving data files:
• Events and setups can be written to a memory card. The card must be formatted

before it can be written to.
• To manually save a data or setup file, refer to the PP4300 TASKCard PQLite User's Guide,

Chapter 7 'Saving Data'.

Append data files (DRAN-VIEW Pro only)
The DRAN-VIEW Pro package allows several files to be merged into one DRAN-VIEW DNV
file. Use this command to add another database file (DNV, MDB or EVT) to the active
document. After the APPEND process, the document will contain data from two individual data
files in a single file. Another APPEND can be issued to add data from a third data-file into the
document and so on. The data from the individual files will be inserted according to their
timestamps. If two data sources overlap (in time) then the file with the most recent starting time
will have priority and therefore overwrites existing data.

Note: Dranview Version 4.0 cannot append files that do not contain waveforms.
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Step 1.
Load the MDB/EVT or DNV file you want to ADD another file into, using the normal File-Open
command. This initial file will be referred to as the Document in the following steps.
Step 2.
Make sure that the target document has been selected on the screen, and then run the File-
Append command. This will bring up a dialog that looks like a File-Open dialog.
Select the MDB, EVT or DNV file you want to insert into the target document.
Step 3.
The following dialog box shows the relationship of the two files. If the bars overlap then the
oldest file will have its data removed in favor to the data of the newest file in the overlap region.

Press Append to start the conversion.

You may now want to save the document into a new disk file with a new name so the original
data is not overwritten.
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Note: EVT/MDB files will never be modified by this operation. Only the DNV file is changed.
If you take a close look in the event list you will see a new type of event that indicates where in
time the newest file starts (Event number 72 in the example below).

The new “File Join”-event contains a complete set of instrument configurations. When you
select the first event of the joined file DRAN-VIEW uses the “File Join” –event to insert the
instrument configuration context that existed for the joined event file rather than using the old,
possibly invalid configuration. This is shown easily by using the View-Instrument Config
command on an event before the Join Event, and then looking at it again when selecting an
event following the Join-Event.
As an example the Site Information String (&s) that you may include in your chart footers may
change when DRAN-VIEW comes to the File-Join event. This demonstrates that the “Join -
Event” contains both the instrument and the DRAN-VIEW setups of the joined file.

Note: This command is provided primarily as a means to join (concatenate) and merge
databases of similar content and origin. There will be some data loss in the older file in regions
of data overlap. Some caution is indicated to help avoid unexpected or nonsense results. For
instance, combining a 658 with a PP1 PQPlus™ database is not recommended. This command
is best used when appending files measured with the same instrument and on the same
measuring point. At minimum, only append files that have the same line frequency. There is no
theoretical limitation on how many files may be appended. There is however a theoretical
limitation of 32000 events in a DNV file. Before reaching these 32000 events you will find that
DRAN-VIEW starts to become slower and slower due to the huge amount of data. The practical
limitation depends on the performance of your computer.
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ADVISORY ON UPGRADING SRAM CARDS

Please be informed that Dranetz-BMI has obtained a new version of memory cards for the 4300 and PP1,
which are compatible with Windows 2000 and Windows XP. These cards are in stock and will be used in
all future shipments. A number of customers have encountered problems when they have upgraded their
Windows software and we have resolved this. No special drivers are required, just the normal setup
sequence established in Windows.

For those customers who have purchased memory cards in the last year, calendar year 2001, we will
provide the new cards at no cost. The old card must be returned prior to replacement or an order must be
placed in the full amount of the memory card.  If an order is placed for an advance replacement, then a
credit will be issued when the old memory card is returned. Otherwise the invoice will have to be paid.

Domestic Sales Representatives, if needed, please mail in your memory cards directly to Pat Guarraci.

Customers and International Distributors must obtain a Return Material Authorization prior to returning
the cards.

For those customers who purchased prior to Calendar Year 2001 and wish to upgrade, we offer a credit
towards the purchase of a new card. For 2MB memory cards, we will offer credit of $100.00 towards the
purchase of a new memory card. For 4MB memory cards, we offer a credit of $200.00 towards the
purchase of a new memory card.

It is important to note that not all customers use Windows 2000 or Windows XP.  Which means not
everyone needs to get new memory cards.

◄ Return to SRAM Chart


